The DNS Changer: End of the Internet–or not

There has been a lot of talk in the news about this DNS Changer worm, and how it will cause people to lose their internet connection on Monday. I wanted to take a moment to clear some things up, as the news basically points you to the FBI’s site (and their information). The link to their information is here.

So, here we go…

  1. Originally there were over 14 million estimated computers infected with these worms. Through the FBI and ISP’s sending out warnings, that number has decreased dramtically. RIght now, in the US, it’s estimated that only 70,000 devices are infected. (Worldwide stats are available from the FBI.) This is why they’re shutting down the servers.

  2. The FBI set up it’s own DNS Servers at the “rogue” IP Addresses, because with so many infected computers, it would have been catastrophic to shut the sites down cold. Imagine waking up to find that over 14 MILLION people have lost internet access suddenly.

  3. Basically what’s happening is this: DNS is like calling directory assistance and getting someone’s phone number. Your browser does this, when it doesn’t know the address (think phone number) of a website. That virus changed those “Directory Assistance” numbers to it’s own set. So it’s as if you were calling a special number for Directory Assistance, and they gave you what numbers they wanted you to dial (not necessarily the number to the person you were calling). Or they gave you a number that would charge your phone bill on their behalf (like using a Phone card to call).

In terms of DNS, your browser would either get sent to an ad site, porn site, or something else, when you typed in a site name. Or if you did a search, it would fake the results of the search with malicious sites (where you could be infected with other viruses), or it would replace the ads on a legitimate site (since your browser had to get the ads from somewhere), with their own ads. It was hinted that the viruses would also capture your passwords, but I haven’t seen anything openly saying that. Although if someone’s infected with any virus, they’ll want to change their passwords after fixing their computer.

** Another common analogy for DNS is like sending a letter through the Post Office, but to be honest, I’m not sure how this would play out in that scenario.

How do you know if you’re infected with the worm?

The easiest way to check your computer is to visit this site for their steps. They have a page which will tell you (via a green or red background on a picture) if you’re infected or not. One drawback is if your ISP “fixes” or alters DNS entries, it may look like you’re clean, when you’re really not.

As for what to check on your computer, here’s what to do:

For Windows Users:

  1. Click the Start orb, and type cmd in the bottom box (where it says “Search”).
  2. Click on Command Prompt (or cmd) in the results at the top.

** These instructions are for Windows Vista/7 users mainly. In older versions of windows, it would be the start button, then Run… and type cmd, or (in all versions of Windows) you can also press the Windows Key and the R key at the same time, and type cmd in the “Run…” box that pops up.

  1. Type in ipconfig /all (or copy and paste from this post).

You’re going to get a lot of information on the screen. What you’re looking for will say something like this:

Local Area Connection (Ethernet)
IP Address: 192.168.x.x (could be something like 192.168.2.100)
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.x.1 or 192.168.x.254 (whatever the IP Address from your modem or router is)
DNS Servers: xxx.xxx.xxx.xxx
xxx.xxx.xxx.xxx

*Those are what you’re looking for ***

What the link said to do was look at the first set of xxx’s in each DNS server. If it’s in their table, then look at the second set of xxx’s in each server. If that’s in the table, look at the third set, and so on. If at ANY point, you find a set of xxx’s that’s not listed in their table, you can stop. Even if it’s one number.

Here is the table that they are referring to.

Rogue DNS Servers

85.255.112.0 through 85.255.127.255
67.210.0.0 through 67.210.15.255
93.188.160.0 through 93.188.167.255
77.67.83.0 through 77.67.83.255
213.109.64.0 through 213.109.79.255
64.28.176.0 through 64.28.191.255

If your DNS Servers are the same as your “Default Gateway” up above, then you need to log into your modem and check them from it. If you have just a modem, then you’ll probably want to call your ISP for help with this. Unless of course, you’ve logged into it enough times that you know what to do. If you have a separate router (like a Linksys, Cisco, or Netgear router for example) that your computer is plugged into, you should be able to go to their site and get information on how to log in. The steps here are general (as the pages and passwords are different for each router).

  1. In your browser, type in the IP Address for your Default Gateway and hti enter.
  2. On the screen that comes up, type in the username and password for your router (NOTE** if you haven’t changed these from the default (usually admin for both), YOU NEED TO DO THAT!!!!!!!!!!!)
  3. You will be presented with the setup screens for your router. You want to look for the DNS information screens (first look at your Status screens, and if the DNS Entries aren’t there (or are the rogue entries) then look for how to configure them).
  4. If your DNS Entries are the rogue entries in the table, then you need to change them back to “good” ones (or follow whatever steps are needed to have your ISP automatically provide them). Personally, I recommend using Public DNS entries (like 208.67.222.222 and 208.67.220.220 for OpenDNS or 8.8.8.8 and 8.8.4.4 for Google DNS), but it’s your decision whether to use your ISP’s or not.

Apply the changes, and restart your computers after the modem/router restarts. You should be all set for Monday.

For Linux users, you’ll either want to check your /etc/resolv.conf file to see if it has the rogue DNS servers or manually edit your network connections (or router/modem).

And for Mac users, you’ll want to check the instructions from the FBI’s website link.

If your computer is/was infected, you need to take steps to clean it. On the link that I provided above for detecting whether you’re infected, they have links to tools for cleaning your computer. After running these tool(s) and making sure your comptuer is clean, you most defiinitely want to change ALL of your passwords. This goes without saying for any malware that’s on your computer (not just this one).

Good luck, and I’ll see you on Monday (hopefully).

Have a great day:)
Patrick.

A "Health Certificate" for the Internet? Hmmm…..

http://blogs.technet.com/b/microsoft_on_the_issues/archive/2010/10/05/the-need-for-global-collective-defense-on-the-internet.aspx

A few days ago, a Microsoft employee (in their Trustworthy Computing division) posted a blog entry discussing the need for a “health certificate” to allow computers on the Internet. In order to be considered “healthy” your computer must have all available updates (I’m assuming Security here), and updated antivirus, and an updated firewall. And be virus free.

On the surface it sounds good (and in some other levels also). But, there are some considerations that need to be made.

First, what if your operating system doesn’t have (and isn’t easily susceptible to) viruses? I’m looking at Mac OS, Linux, and other unix variants here. Will there be a provision that states only Windows computers require antivirus software? And if, at some point, the other OS’es find the need for antivirus software, will the provision be put in for them?

Secondly, the idea is that they will be completely blocked from the Internet. So, pray tell, how will they block the computer? Will they do it by MAC Address (the “Physical Address of the Network Card)? Or will they block it at the modem level? This presents two problems: If the computer has multiple NIC’s (wired and wireless for example), they can still get on the Internet for a brief time. Also, how will the user get the needed updates to get their “health certificate”?

Thirdly, what exactly would the “health certificate” be? Will it be like a Digital Certificate? Will it be like the Windows Activation? How will they prevent people from forging their certificates or stealing others?

Fourth, how will this keep me from screwing up my facebook with those stupid lolzvideo viruses that are floating around? (I don’t click those, but I know a lot of people who do) After all, no antivirus protects you from that. And I would imagine that for the average person, that is the biggest hassle. They don’t realize the other dangers, because they don’t play in the big park. They go to their email and surf facebook and youtube.

The Health Certificate is a good theory. If someone actually decides to implement it, it needs to be an independent party with NO interests in any operating system or security software. Because if you have an interest in a product that the health certificate affects, you’re inherently going to shift the balance in favor of your interests. In other words, Microsoft has a good idea, but they shouldn’t have anything to do with implementing it.

One telling thing about this is that between 1 and 10 million Windows PC’s are involved with botnets. The number of Macs, Linux PC’s/Servers, and other devices that run non-Windows code is closer to zero. Now that may change if virus creators figure out a way to hack through OS X or Linux. But the point is that right now, it’s more than likely a Microsoft product that is causing the problems.

All of this being said, I think the health certificates are a decent idea. And after skimming through the actual white-paper on the subject, it raises some good points that aren’t being covered in the media.

Personally I think that the “Health Certificates” should contain the following information:

1. All MAC Addresses in the computer (this should be the ONLY identifiable information)
2. Operating System information (Windows/Linux/OS/etc and version including build where appropriate).
3. A check to see if all required security updates are installed properly.
4. If the Operating System requires a firewall and antivirus, whether these are present, turned on, and updated completely.

The “Health Certificate” should be generated on the fly. This will ensure that the most current information is presented. Tools like Belarc Advisor already generate the information that I suggest (and could easily be incorporated into the Health Certificate program).

Let me know what you think of the Health Certificate ideas. Read the white-papers on the Microsoft site, and do a little research into the idea. Let me know what you’d like to see in one (if they’re implemented).

Have a great day:)
Patrick.

Configuring a Cisco Router to support a LAN on DSL

One of the things that I accomplished in the past month was to convert my network from a “modem to consumer router to computers” to a “modem to Cisco Enterprise Router to Cisco Enterprise Switch to computers (with the consumer router proving wireless access).  And on top of that, I enabled IPv6 on the entire network with my /64 network from Hurricane Electric.  Both feats took some effort to accomplish, although I owe a great deal of thanks to the people at DSL Reports Cisco Hardware Forums.

To make someone else’s life a little easier, I’m posting my completed (sanitized to remove passwords and actual IP Addresses) configuration file for the router up here.  As for the switch, I simply configured one vlan (vlan 1) with an IP Address from my excluded IP’s and configured security on it.  If the text has a * or () then it’s a comment.

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname whatrouteriscalled
!
boot-start-marker
boot-end-marker
!
enable secret 5 removed-password
!
no aaa new-model
ip subnet-zero
ip cef
ip dhcp excluded-address eth0 ipv4 address
ip dhcp excluded-address switch vlan management ipv4 address
ip dhcp excluded-address server ipv4 address
ip dhcp excluded-address wireless router ipv4 address
ip dhcp excluded-address optional ipv4 (needed for a desktop
ip dhcp excluded-address second wireless router ipv4 address (open wireless)
!
ip dhcp pool internal-network
   network ipv4network (.0) 255.255.255.0
   default-router eth0 ipv4 address
   dns-server 208.67.222.222 208.67.220.220 (OpenDNS Public IPv4 addresses)
!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
ipv6 unicast-routing *enables IPv6 and allows for routing
!
!
!
!
interface Tunnel0
description Hurricane Electric IPv6 Tunnel Broker
no ip address
ipv6 address client-side ipv6 address/64
ipv6 enable
tunnel source Dialer1
tunnel destination server side ipv4 address for he.net
tunnel mode ipv6ip
!
interface Ethernet0
description My LAN Interface
ip address eth0 ipv4 address 255.255.255.0
ip nat inside
no ip mroute-cache
ipv6 address ipv6 network address/64 eui-64 *(ends in ::)
ipv6 enable
no cdp enable
!
interface Ethernet1
description Physical ADSL Interface (Facing the ISP)
no ip address
no ip mroute-cache
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
no cdp enable
!
interface Serial1
no ip address
no ip mroute-cache
shutdown
no cdp enable
!
interface Dialer1
description Logical ADSL Interface
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname username provided by ISP
ppp chap password 7 encrypted password provided by ISP
ppp pap sent-username username provided by ISP password 7 encrypted password from ISP
!
ip nat inside source list 10 interface Dialer1 overload
ip nat inside source static tcp server ipv4 address 4125 interface Dialer1 4125
ip nat inside source static tcp server ipv4 address 443 interface Dialer1 443
ip nat inside source static tcp server ipv4 address 80 interface Dialer1 80
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
access-list 10 permit ipv4 network (.0) 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
ipv6 route ::/0 Tunnel0
!
!
line con 0
exec-timeout 120 0
password 7 password (encrypted)
login
stopbits 1
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 password (encrypted)
no login
length 0
!
scheduler max-task-time 5000
end

Some notes…  The ! are ignored by the router, so you don’t need to put them in.  If you want to create comments for what things are doing, you’ll precede them with the ! (and the router will throw them out when it’s configuring).

It was recommended that I (and you) use service password-encryption which will automatically encrypt any passwords (minimizing the need for removing them).  If you use this, and it puts a “7” before the password, you still need to remove it (as the encryption is weak) but if it has a “5” before it (like the enable secret does) it’s stronger.  Personally, I’ll remove them all from the config anyhow.

This should be considered a starting point for you, as everyone’s situation is different.  And this should be a starting point, if you’re interested in learning (for your CCNA or CCNP or just for the sheer joy of it) about Cisco configurations.

Have a great daySmile
Patrick.

IPv6 accessible websites

This is going to be a list of IPv6 accessible websites.  Some of them will be accessible regardless of whether you have IPv6 enabled or not, but others will only be available via IPv6.  As I get more, I will add them to the list…  Here we go.

http://penrose.uk6x.com/ Countdown to the exhaustion of IPv4 addresses

Checking to see whether you have IPv6 enabled:

http://www.whatismyipv6.com

http://www.ipv6.org (also has information and an older list of sites)

http://ipv6.whatismyipv6.net.ipv4.sixxs.org/

http://www.runningipv6.net/what-is-my-ipv6-address.php

Search engines:  (There’s only one that actually has an IPv6 address that I know of)

http://ipv6.google.com (will return an error if you don’t have IPv6 enabled)

A list of Internet Providers who will give you an IPv6 address (I’m going to call a few around the US to find out if they offer it as well)

http://www.sixxs.net/faq/connectivity/?faq=native

http://ipv6.comcast.net/ Comcast is running IPv6 trials, and has this portal

 http://www.ast.cam.ac.uk/ Cambridge University Institute of Astronomy (IPv6 only)

http://www.ipv6.org.uk/workshop/ Workshop with different information on IPv6

http://www.surgeradio.co.uk/ Surge Radio (UK)

www.ipv6.ecs.soton.ac.uk IPv6 at Southampton University (may not load)

And most importantly…..

www.v6.facebook.com  Facebook has IPv6 access.  Now that’s a reason to switch (granted it looks the same as IPv4, but by using it, you’ll be helping the Internet)

I’ve sent comments to LinkedIN and MySpace to find out if, and when, they’ll have IPv6 capabilities.  Also, Google has IPv6 capability enabled on quite a few of their sites.  Including YouTube.

Comcast is testing out IPv6 and will hopefully phase it in within the next year.  This is the dilemma for people.  Everyone knows that the end of IPv4 is coming.  And most know that it will be within the next two years.  But, since they believe that even after all of the IPv4 addresses are doled out they’ll still be able to function, no one’s in a hurry to transition.  So, it’s up to US the people to convince them to make the change.

As I get more sites, I’ll update this list.

Have a great daySmile
Patrick.

Grandma endures wrongful ISP piracy suspension

Grandma endures wrongful ISP piracy suspension

Luckily for Cathi Paradiso, she was able to prove that the illegal downloading was not her fault.  Unfortunately, she fell victim to something that a lot of broadband users are unaware of.  The use of their internal networks for illegal means.

Cathi has a Qwest DSL modem.  Either she had wireless connectors at one time, or it was enabled for some other reason.  The wireless network WAS NOT SECURED, and people were using her modem as a gateway.  Some of them were downloading movies and television shows.  Her DSL was suspended due to this illegal downloading.

The article goes into the argument about whether ISP’s should be the Copyright Cops or not.  I’m going in a different approach—although I do have an opinion on that issue.  I’m looking at what YOU need to do to make sure that you’re not a victim (or make sure that the “Copyright Cops” have no reason to look at you).

If you do not have any wireless computers connected to your network, shut off the wireless on all routers, switches, and modems.  In the settings screen (one of them should be labeled Wireless or something similar), you should have the option to “Enable” or “Disable” wireless access.  Disable it.

If you do have wireless computers, make sure you’re using PKA or PKA2 (preferred) for your wireless security.  When you enable this, you’ll create a passphrase (NOT A PASSWORD) like “My very elderly mother just said Uh No Problem.”  (this is a phonetic to remember the planets back when Pluto was considered one).  You want to make it something that people can’t guess easily.  So, don’t make it your favorite quote, or a phrase that you blog about.  Make it something only you, and maybe your immediate family will remember.

I recommend OpenDNS for your DNS needs.  Your ISP will automatically supply you with their DNS, but OpenDNS will allow you to filter (read block) sites based on categories.  So, you can block movies and music and file sharing sites.  Of course this only works if the person jumping onto your network doesn’t have their own DNS specified (although if they have OpenDNS specified, it will use yours—not theirs).

Make sure that your router, modem, and OpenDNS passwords are strong.  It should be a minimum of 8 characters, contain Upper- and lower-case letters, numbers, and/or symbols.  And it should not be something that you blog or talk about (no pet names or anniversaries).  In fact, it needs to be fairly random—not really a word at all.

These tips won’t guarantee that you’ll never fall victim to copyright thieves (or the ISP or entertainment industry), but they will go a long ways towards protecting you.  So, please take the time to learn how to secure and set up your equipment, and make sure you do it.

Have a great day:)
Patrick.

Google Joins the IE-6 Must Die Campaign

http://www.computerworld.com/s/article/9150138/Google_joins_the_kill_IE6_campaign

ComputerWorld is reporting that starting on March 1, 2010, Google Docs and Google Sites will no longer support Internet Explorer 6.  Considering that IE6 is 9 years old, it’s not surprising.  There have been two versions of Internet Explorer in the past 9 years, alongside offerings from Mozilla, Apple, and even Google themselves.  Corporations have NO excuses for not updating their applications and services to support the later versions of Internet Explorer (or the alternative browsers). 

If you are a web-developer, I strongly urge you to drop support for Internet Explorer 6 in your sites.  Redirect the visitor to a page that says something to the effect of "The browser that you are currently using is old, outdated, and insecure.  Here are some links to the latest browsers which are supported on this site."  In fact, I would suggest following Google’s lead and dropping support for Firefox 2.x, Apple 2.x, Google 3.x, or earlier browsers.

Here are some links for coding the version detection into your websites. 

http://www.mozilla.org/docs/web-developer/sniffer/browser_type_oo.html This page is geared mainly for older browsers to show the page in an optimized format.  You can easily modify the code to redirect the user to another page that recommends they upgrade.  (instead of (ie5up), you could use (! ie7up)).

http://www.quirksmode.org/js/detect.html The code in this site parses the browser’s information for the version number.  You can modify their example inside of the "You are using…." box to create your redirection (if browser < IE7, Firefox 3, Chrome 4, then redirect here.).  This script does not detect Safari–due to how Apple formats their browser identification string, but you could probably add it in fairly easily (you just need to know the internal version number of Safari 4 which is any number greater than 528.18.  It’s 530.17 on Mac, 530.17 on Windows (4.0.1) but 528.18 on their iPhone, so I would just use the lower value because there are no "versions" on the Mac or Windows that contains that number (source http://en.wikipedia.org/wiki/Safari_version_history )).

Personally, I prefer the second route to the first one.  I may include it in my blog at some point (redirecting people to this post or another page).  However on the first page, they actually discuss the >= or in your case < (use gte for >= and lt for < in your if statements).

Have a great day and if you’re using one of these older browsers, then you may want to switch things up.  http://www.microsoft.com/windows/internet-explorer/default.aspx http://www.getfirefox.com or http://www.apple.com/safari

Patrick.

Microsoft Releases Out of Band Update for Internet Explorer

If you haven’t heard this already, there was an incident where Google and about 20 other companies were hacked last month.  It allegedly is tied into the Chinese Government.  Because of this, a few things have taken place.

Google is threatening to pull their Search engine out of China (at the very least they are threatening to stop censoring search results at the request of the Government) and they threatened to delay the release of their new phone in China.

People were throwing blame around at different companies and different applications for this hack.  It turned out that the hack was done on Internet Explorer 6.x—due to an unannounced vulnerability.

Microsoft is reported to be releasing an out-of-band update today for this vulnerability.  They also recommend the following steps to mitigate it:

  • If you are running Internet Explorer 6, it’s time to upgrade. 
  • Regardless of whether you are planning on upgrading, you should set your Internet Zone to “High”
  • Internet Explorer 7 and 8 users (on Vista or Windows 7) should enable “Protected Mode”.
  • All users should enable Data Execution Prevention (DEP) on their computers.  DEP prevents the computer from executing code which is stored in memory that is supposed to only contain non-executable code.
  • You should be running in non-Administrative accounts (or have UAC enabled) to restrict the rights of an infected user.  This is something that everyone has been preaching since the dawn of Windows XP.

There are people who are trying to tweak this vulnerability to work in Internet Explorer 7 and 8 on Vista and Windows 7.  One of the people claims that DEP won’t mitigate this, if the application doesn’t “opt-in” to it.  I’m not sure if he is referring to Internet Explorer (which you will opt-in by enabling DEP) or the malicious code.  Also I’ve read that some systems (namely netbooks and older CPU’s) do not have “Hardware DEP”, so enabling it doesn’t actually work. ***I can’t verify this***

So, what should you do???

First and foremost you need to get updates.  This is regardless of whether you use Internet Explorer or not.  It’s better safe than sorry—especially since some programs do not follow the rules about default browsers.

This is a good time to try out Firefox with the No-Script addon and also Google Chrome.  I would even suggest Apple Safari, but I haven’t used it very much to know what it’s limitations are.

Some people would say this is the time to remove Windows, and switch to another Operating System (namely Linux) or buy a Macintosh.  While I love Linux, I don’t think that is the best solution in this case (although I would encourage people to try a Live CD out).  And I definitely cannot recommend spending $1,000+ on a new computer—just to get a Macintosh.

The short end of the stick is this.  Update your computer after 10:00 am PST today.  I would recommend an alternative browser.  However, since this potentially affects Outlook, Outlook Express, Windows Mail, Windows Live Mail, and anything else that uses Internet Explorer, you NEED to update the computer.

On a side note, Microsoft is also releasing an advisory about a Kernel vulnerability.  This requires the attacker to be able to log into your computer from your computer (meaning not from the Internet).  It remains to be seen if they will have a patch for this today or not.

Have a great day:)
Patrick.

How to protect yourself against the Chinese Google hack – Computerworld Blogs

How to protect yourself against the Chinese Google hack – Computerworld Blogs

By now you probably have heard about the “Google Hack”.  If not, here’s a recap.  Earlier in the week, Google announced on their blog that they were hacked in November (along with other companies in the Financial, Technology, and utility sectors).  They posted that the hacking came from China, and in their case was limited to the Gmail accounts of Chinese bloggers and Chinese activists.

Google also announced that due to this attack, along with their feelings on censorship and freedom, they are no longer going to censor results in China—in other words, no more Google in China. 

A lot of speculations where floating around about how the hackers were able to get the information.  People were blaming Adobe (because of the flaws in their products).  Well, it turns out that it’s Internet Explorer that’s being exploited.

This article goes into detail about how to limit your chances of being hacked through this vulnerability, and is especially important because the exploit is being “sold” in Hacking tookits.

One idea that wasn’t mentioned is using Firefox or Chrome to surf the web.  Also, if you’re running Vista or Windows 7, you need to have UAC enabled (as much as it sucks in Vista).  If you’re running XP or 2000 then you need to have a Non-Administrator account, and be using that for your daily actions.  Only use your “Computer Administrator” or “Administrator” accounts when YOU are intentionally installing something.

You NEED to read the linked blog post, as the author goes into great detail about how to check to see if you’re protected, and enable it if not.

Have a great day:)
Patrick.

Disasters and Scams Seem to Go Hand in Hand

The earthquake in Haiti last evening is a tragedy and a catastrophe. And the natural desire to help is a very well-placed thing and should be acted upon. However, there are people who are more than happy to take advantage of our desires to help out.

Already there are a bunch of domain names being registered referencing the Haiti Disaster (http://isc.sans.org). They don’t specify how many or what names, but I’ll bet by the end of the day, a list will be up.  This happens after every major disaster—or major news event.  While some (or most) of the sites may be legitimate, there will be a large number that are not. 

There is a new method going around also.  Sending SMS requests via Twitter and Facebook.  These messages say something like “SMS yele to xxxxx to donate $5 ($10) to Haiti”.  Some will tell you that the donation is charged to your cell phone—others won’t. I’m not saying that you shouldn’t do this—I’m saying that you need to be aware of two things: 1) You’re going to see a $5.00 SMS charge on your phone bill (regardless of your “Text Messaging Plan” and 2) you honestly don’t know if that money will go to the Haiti Disaster, or someone’s lifestyle.

If you’re in the United States (and probably other countries as well), your best bet is to go to http://www.redcross.org (The American Red Cross) and donate through them.  If you’re interested in the SMS route, try http://www.mgive.com or http://mobilegivinginsider.com as they are vetted by ISC.  The American Red Cross is also on Twitter at http://www.twitter.com/redcross (or @redcross).

If you have SMS “Premium blocking” enabled on your phone, you may have to call your wireless carrier first to approve the donation (or disable it while you do the donation).  My suggestion is to monitor it to find out if you’re suddenly donating every day.  If so, then you need to block the charges.

As I said, this is already a tragedy and a catastrophe. Please don’t let it become a financial tragedy for you.  Donate—but do it through legitimate sources.  Check the ISC lists and check out the site (and entities behind the sites) BEFORE you donate.

Myself, I’m waiting to see what my local chapter of Phi Theta Kappa is going to do.  I’ll help them, or I’ll make a donation to the Red Cross.  Maybe, I’ll even donate blood (since that will be needed as badly as money).

Have a great day:)
Patrick.

Password Security revisited

If your password is on this list, then you can be sure of two things:  1) You’ll never be able to log into Twitter with this password, and 2) It’s so easily guessed that you should be surprised no one has hacked your accounts already.

The list is the 370 passwords that Twitter has banned because they are too easy.  It’s a small drop in the bucket of “dictionary words” and other weak passwords that you should avoid using.

If you want some tips on changing your password, then check out my related posts, or search for “how to create strong passwords” on Google.

Have a great day:)
Patrick.